Account & Permissions FAQs

What are the minimum computer requirements to use GoCo?

GoCo requires a modern web browser that supports the following:

  • HTML4+
  • Javascript ES5+
  • CSS3
  • Web Worker API support

We recommend using the latest most up-to-date version of these web browsers:

If you are using one of the above browsers but are still experiencing issues with GoCo, please try some of our Basic Troubleshooting Tips.

If you need additional assistance, please email us at help@goco.io! 💚